Switching Lab 6 : STP Features : UplinkFast

Switching Lab 6 : STP Features : UplinkFast

  • 17 September 2021
  • Network
  • Ditulis oleh Ajriya Muhammad Arkan
  • 62 Views

Switching Lab 6 : STP Features : UplinkFast

 

LAB 6

Fungsinya sama seperti portfast, hanya saja perlu diingat bahwa portfast tidak boleh dikonfigurasikan pada trunk karena akan mengakibatkan spanning tree nyamenjadi disable. Nah untuk hal tersebut yakni agar port bisa langsung forward tanpa perlu menunggu listening dan forwarding dulu, kita bisa konfigurasikan UPLINKFAST. Sehingga bila link utamanya down, maka link backupnya bisa langsung UP seketika tanpa perlu oranye dulu portnya. 

▪ Konfigurasikan trunk pada kedua link diatas 

▪ Konfigurasikan spanning tree uplinkfast padaSW1 

Konfigurasi uplinkfast 

SW1

IOU1(config)#vlan 12 
IOU1(config-vlan)#name Bebas 
IOU1(config-vlan)#interface vlan 12 
IOU1(config-if)#ip address 12.12.12.1 255.255.255.0 
IOU1(config-if)#no shutdown 

IOU1(config)#int e0/0 

IOU1(config-if)#switchport trunk encapsulation dot1 
IOU1(config-if)#switchport trunk encapsulation dot1q 
IOU1(config-if)#switchport mode trunk 

IOU1(config)#int e0/1 

IOU1(config-if)#switchport trunk encapsulation dot1q 
IOU1(config-if)#switchport mode trunk

SW2

IOU2(config)#vlan 12 
IOU2(config-vlan)#name Bebas 

IOU2(config-vlan)#interface vlan 12 

IOU2(config-if)#ip address 12.12.12.2 255.255.255.0 
IOU2(config-if)#no shutdown 

IOU2(config-if)#int e0/0 

IOU2(config-if)#switchport trunk encapsulation dot1q 
IOU2(config-if)#switchport mode trunk 

IOU2(config-if)#int e0/1 

IOU2(config-if)#switchport trunk encapsulation dot1q 
IOU2(config-if)#switchport mode trunk 
IOU2(config-if)#end 

Kita cek terlebih dahulu port mana yang digunakan dan port sebagai backup.

SW2

IOU2#sh spanning-tree vlan 12 
VLAN0012
 Spanning tree enabled protocol ieee 
 Root ID Priority 32780 
 Address aabb.cc00.0100 
 Cost 100 
 Port 1 (Ethernet0/0) 
 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec 
Bridge ID Priority 32780 (priority 32768 sys-id-ext 12) 
 Address aabb.cc00.0200 
 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec 
 Aging Time 300 sec Interface Role Sts Cost Prio.Nbr Type 
------------------- ---- --- --------- -------- -------------------------------- 
Et0/0 Root FWD 100 128.1 Shr 
Et0/1 Altn BLK 100 128.2 Shr

Kita bisa melihat bahwa jalur e0/0 yang digunakan sedangkan e0/1 dalam kondisi blocking. Kita bisa melakukan pengetesan dengan tes ping dari SW2 ke SW1 repeat 10000 terlebih dahulu. Setelah jalan pingnya, kita shutdown interface e0/0nya dari SW1.

Kita bisa melihat bahwasanya jalur e0/0 yang digunakan, sedangkan e0/1nya dalam kondisi blocking. Pengetesan yang bisa dilakukan yaitu dengan tes ping dari dari SW2 ke SW1 repeat 10000 terlebih dahulu Setelah jalan pingnya shutdown interface E0/0 nya SW1.

SW2

SW2(config)#do ping 12.12.12.1 re 10000 
Type escape sequence to abort. 
Sending 10000, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds: 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
Success rate is 99 percent (9976/10000), round-trip min/avg/max = 1/4/4294967295 ms 

SW1

SW1(config)#int e0/0 
SW1(config-if)#shutdown 
SW1(config-if)#exit 

Terlihat cukup banyak RTO nya saat proses perpindahan jalur ketika link e0/0 nya down dan kemudian berpindah ke e0/0. Selanjutnya konfigurasikan uplink fast pada SW1

SW2

SW2#ping 12.12.12.1 re 10000 Type escape sequence to abort. 
Sending 10000, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds: 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
Success rate is 99 percent (9992/10000), round-trip min/avg/max = 1/4/92 ms 

Terlihat bahwasanya RTO nya hanya 2 kali, jauh lebih sedikit dibanding sebelumnya. Kalau pada perangkat switch sebenarnya malah tidak ada RTO sama sekali. Disini RTO nya muncul karena menggunakan GNS3 yang cukup memakan resource cpu dan memory.

SW1

SW1(config)#interface e0/0 
SW1(config-if)#shutdown 
*Des 9 15:44:52.837: STP FAST: UPLINKFAST: make_forwarding on 
VLAN0001 Ethernet0/1 root port id new: 128.2 prev: 128.1 
*Des 9 15:44:52.837: %SPANTREE_FAST-7-PORT_FWD_UPLINK: VLAN0001 
Ethernet0/1 moved to Forwarding (UplinkFast).


C

  • Tags:
  • -
  • Share: